summaryrefslogtreecommitdiff
path: root/src/ipa/raspberrypi/data/meson.build
diff options
context:
space:
mode:
authorDavid Plowman <david.plowman@raspberrypi.com>2021-03-08 22:39:38 +0000
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-03-09 00:54:23 +0200
commit8f3a54ae6a53076ebba44b13dbe237e348bd6d27 (patch)
tree0c7858e483db46f4a5476130ecbe8bce096abb40 /src/ipa/raspberrypi/data/meson.build
parent18691c538b9dad777bd61fe8400289298c78ac10 (diff)
ipa: raspberrypi: Add support for imx290/imx327 sensors
imx290 and imx327 share the same kernel driver (imx290.c) and are therefore both recognised here as "imx290". We add the necessary CamHelper for these sensors, as well as a camera tuning file. The tuning was done with an Innomaker STARVIS IMX327LQR module. These have no IR cut filter so there is no proper colour tuning. However, you should obtain reasonable results for most modules using this sensor. Specific tunings for further modules can always be added subsequently. To use this sensor on the Raspberry Pi platform, please add dtoverlay=imx290,clock-frequency=74250000 into your /boot/config.txt file. Signed-off-by: David Plowman <david.plowman@raspberrypi.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/ipa/raspberrypi/data/meson.build')
-rw-r--r--src/ipa/raspberrypi/data/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipa/raspberrypi/data/meson.build b/src/ipa/raspberrypi/data/meson.build
index 5236bf1e..41fd02e3 100644
--- a/src/ipa/raspberrypi/data/meson.build
+++ b/src/ipa/raspberrypi/data/meson.build
@@ -2,6 +2,7 @@
conf_files = files([
'imx219.json',
+ 'imx290.json',
'imx477.json',
'ov5647.json',
'uncalibrated.json',