summaryrefslogtreecommitdiff
path: root/src/ipa/raspberrypi/data/meson.build
diff options
context:
space:
mode:
authorNaushir Patuck <naush@raspberrypi.com>2023-05-03 13:20:27 +0100
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2023-05-04 20:47:40 +0300
commit726e9274ea95fa46352556d340c5793a8da51fcd (patch)
tree80f6adcdbf744f9317e09eff3e80c602b384a753 /src/ipa/raspberrypi/data/meson.build
parent46aefed208fef4bc8d6f6e8882b92b9af710a60b (diff)
pipeline: ipa: raspberrypi: Refactor and move the Raspberry Pi code
Split the Raspberry Pi pipeline handler and IPA source code into common and VC4/BCM2835 specific file structures. For the pipeline handler, the common code files now live in src/libcamera/pipeline/rpi/common/ and the VC4-specific files in src/libcamera/pipeline/rpi/vc4/. For the IPA, the common code files now live in src/ipa/rpi/{cam_helper,controller}/ and the vc4 specific files in src/ipa/rpi/vc4/. With this change, the camera tuning files are now installed under share/libcamera/ipa/rpi/vc4/. To build the pipeline and IPA, the meson configuration options have now changed from "raspberrypi" to "rpi/vc4": meson setup build -Dipas=rpi/vc4 -Dpipelines=rpi/vc4 Signed-off-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: Jacopo Mondi <jacopo.mondi@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/ipa/raspberrypi/data/meson.build')
-rw-r--r--src/ipa/raspberrypi/data/meson.build26
1 files changed, 0 insertions, 26 deletions
diff --git a/src/ipa/raspberrypi/data/meson.build b/src/ipa/raspberrypi/data/meson.build
deleted file mode 100644
index b163a052..00000000
--- a/src/ipa/raspberrypi/data/meson.build
+++ /dev/null
@@ -1,26 +0,0 @@
-# SPDX-License-Identifier: CC0-1.0
-
-conf_files = files([
- 'imx219.json',
- 'imx219_noir.json',
- 'imx290.json',
- 'imx296.json',
- 'imx296_mono.json',
- 'imx378.json',
- 'imx477.json',
- 'imx477_noir.json',
- 'imx477_scientific.json',
- 'imx519.json',
- 'imx708.json',
- 'imx708_noir.json',
- 'imx708_wide.json',
- 'imx708_wide_noir.json',
- 'ov5647.json',
- 'ov5647_noir.json',
- 'ov9281_mono.json',
- 'se327m12.json',
- 'uncalibrated.json',
-])
-
-install_data(conf_files,
- install_dir : ipa_data_dir / 'raspberrypi')