summaryrefslogtreecommitdiff
path: root/src/ipa/meson.build
diff options
context:
space:
mode:
authorUmang Jain <umang.jain@ideasonboard.com>2022-09-14 16:28:59 +0530
committerUmang Jain <umang.jain@ideasonboard.com>2022-09-15 15:56:19 +0530
commiteb7e83b346a8dbfe4259a947ca73ed08ceb558a4 (patch)
tree98d6fadf5820e765937331ef7db15154878333d0 /src/ipa/meson.build
parent0a4d1b8d452ad8b3ab11e27c5497f8e5f6b2b20b (diff)
meson: Enable vimc IPA for tests
Vimc pipeline handler is enabled unconditionally if the meson config option '-Dtest' is true. However, this is not true for the vimc IPA. Hence, a meson configuration such as: -Dpipelines=raspberrypi -Dipas=raspberrypi -Dtest=true will include the vimc pipeline handler (in addition to raspberrypi) but will skip the vimc IPA which can lead to failure of unit tests that depends on vimc to execute. One such unit test was identified as a result of this issue on RaspberryPi: ERROR IPAModule ipa_module.cpp:278 ipa_vimc.so: Failed to open IPA library: No such file or directory test IPA module src/ipa/vimc/ipa_vimc.so is invalid due to the non-existent ipa_vimc.so. Fix this by including the vimc IPA unconditionally when the tests are enabled, similar to how the vim pipeline-handler is included. Fixes: 6e65d4225736 ("libcamera: Enable vimc pipeline handler when tests are enabled") Signed-off-by: Umang Jain <umang.jain@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/ipa/meson.build')
-rw-r--r--src/ipa/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/ipa/meson.build b/src/ipa/meson.build
index 849bb372..e972bbe8 100644
--- a/src/ipa/meson.build
+++ b/src/ipa/meson.build
@@ -27,6 +27,14 @@ ipa_sign = files('ipa-sign.sh')
ipa_names = []
ipa_modules = get_option('ipas')
+
+# Tests require the vimc IPA, similar to vimc pipline-handler for their
+# execution. Include it automatically when tests are enabled.
+if get_option('test') and 'vimc' not in ipa_modules
+ message('Enabling vimc IPA to support tests')
+ ipa_modules += ['vimc']
+endif
+
enabled_ipa_modules = []
# The ipa-sign-install.sh script which uses the ipa_names variable will itself