summaryrefslogtreecommitdiff
path: root/src/ipa/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2023-05-08 15:50:26 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2023-05-09 06:35:47 +0300
commite8fccaea46b9e545282cd37d54b1acb168608a46 (patch)
treee4f817aa691d3258b38539ed729e3d18676c152f /src/ipa/meson.build
parent120e313450502d0bfda0e6a0e4de3c8f34d27a75 (diff)
meson: Fix usage of overwritten pipeline variable
When iterating over enabled pipelines and IPA modules, libcamera descends into subdirectories in a recursive manner, which involves nested loops. Both the outer and inner loops use the same loop variable named 'pipeline'. As the outer loop uses the variable after descending into the inner directory, it ends up using an incorrect value. Fix it by moving all use of the variable before the subdir() call, and add a comment that warns about the issue to avoid reintroducing it. Fixes: e8526c0c2bc6 ("ipa: meson: Allow nested IPA directory structures") Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Jacopo Mondi <jacopo.mondi@ideasonboard.com> Reviewed-by: Umang Jain <umang.jain@ideasonboard.com>
Diffstat (limited to 'src/ipa/meson.build')
-rw-r--r--src/ipa/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/ipa/meson.build b/src/ipa/meson.build
index 289f861c..903eb52b 100644
--- a/src/ipa/meson.build
+++ b/src/ipa/meson.build
@@ -52,8 +52,11 @@ foreach pipeline : pipelines
continue
endif
- subdir(pipeline)
subdirs += pipeline
+ subdir(pipeline)
+
+ # Don't reuse the pipeline variable below, the subdirectory may have
+ # overwritten it.
endforeach
# The ipa-sign-install.sh script which uses the enabled_ipa_modules variable