summaryrefslogtreecommitdiff
path: root/src/ipa/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2019-09-27 04:44:16 +0200
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2019-10-11 15:30:54 +0200
commitbf0915a4e808247fc26d817e66cc20e6d15067d3 (patch)
tree45271930b6001b0f10a43cc3f9f4bda2f69b6f4b /src/ipa/meson.build
parent97dce7a13fa373b5153335f8e47bdfac54014ad8 (diff)
libcamera: ipa: rkisp1: Add basic control of auto exposure
Add an IPA which controls the exposure time and analog gain for a sensor connected to the rkisp1 pipeline. The IPA supports turning AE on and off and informing the camera of the status of the AE control loop. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/ipa/meson.build')
-rw-r--r--src/ipa/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/ipa/meson.build b/src/ipa/meson.build
index ac16e1da..4f2a4577 100644
--- a/src/ipa/meson.build
+++ b/src/ipa/meson.build
@@ -22,3 +22,5 @@ endforeach
config_h.set('IPA_MODULE_DIR',
'"' + join_paths(get_option('prefix'), ipa_install_dir) + '"')
+
+subdir('rkisp1')