summaryrefslogtreecommitdiff
path: root/src/ipa/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-03-25 09:36:35 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-03-25 12:21:06 +0200
commita25533089bda04daf0243eda7e316baea0737e19 (patch)
tree8997f2c22a0861e0da134a9a1c099f02bd9a7f57 /src/ipa/meson.build
parent5e8933eeebcedda55d4c4e84db9b4983eecefe1b (diff)
ipa: Move vimc to a subdirectory
Give a subdirectory to all IPA modules to make the structure of the source tree more consistent. This will also simplify the implementation of IPA module selection at build time. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'src/ipa/meson.build')
-rw-r--r--src/ipa/meson.build20
1 files changed, 2 insertions, 18 deletions
diff --git a/src/ipa/meson.build b/src/ipa/meson.build
index 42180324..9aaf9249 100644
--- a/src/ipa/meson.build
+++ b/src/ipa/meson.build
@@ -1,8 +1,3 @@
-ipa_vimc_sources = [
- ['ipa_vimc', 'LGPL-2.1-or-later'],
- ['ipa_vimc_isolate', 'Proprietary'],
-]
-
ipa_install_dir = join_paths(get_option('libdir'), 'libcamera')
ipa_includes = [
@@ -10,20 +5,9 @@ ipa_includes = [
libcamera_internal_includes,
]
-subdir('libipa')
-
-foreach t : ipa_vimc_sources
- ipa = shared_module(t[0], 'ipa_vimc.cpp',
- name_prefix : '',
- include_directories : ipa_includes,
- dependencies : libcamera_dep,
- link_with : libipa,
- install : true,
- install_dir : ipa_install_dir,
- cpp_args : '-DLICENSE="' + t[1] + '"')
-endforeach
-
config_h.set('IPA_MODULE_DIR',
'"' + join_paths(get_option('prefix'), ipa_install_dir) + '"')
+subdir('libipa')
subdir('rkisp1')
+subdir('vimc')