summaryrefslogtreecommitdiff
path: root/src/ipa/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2019-06-03 13:19:44 -0400
committerPaul Elder <paul.elder@ideasonboard.com>2019-06-05 10:44:52 -0400
commit7fa98a4cdd296c86fe053ab17486c1e0e2a72e90 (patch)
treed038f64587b41f02f9ec928a6181ec72589b5b97 /src/ipa/meson.build
parent42c9b4bad40b462ef267b477e136202f02071137 (diff)
libcamera: ipa_manager: implement class for managing IPA modules
IPAManager is a class that will search in given directories for IPA modules, and will load them into a list. It also provides an interface for pipeline handlers to acquire an IPA. A meson build file for the IPAs is added, which also specifies a hard-coded path for where to load the IPAs from in the installation directory. More paths can be specified with the environment variable LIBCAMERA_IPA_MODULE_PATH, with the same syntax as the regular PATH environment variable. Make the test framework set this environment variable. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/ipa/meson.build')
-rw-r--r--src/ipa/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/ipa/meson.build b/src/ipa/meson.build
new file mode 100644
index 00000000..be4f9547
--- /dev/null
+++ b/src/ipa/meson.build
@@ -0,0 +1,2 @@
+config_h.set('IPA_MODULE_DIR',
+ '"' + join_paths(get_option('prefix'), get_option('libdir'), 'libcamera') + '"')