summaryrefslogtreecommitdiff
path: root/src/ipa/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-02-22 23:05:46 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-02-23 12:53:15 +0200
commit6e65d4225736cec2fb58168e0e66951483f13903 (patch)
tree5f490f772ac9bee0e6c6bccd7babd26e64296a25 /src/ipa/meson.build
parent6c4ce7de30c87a785001bc1e6632aa7b401854ce (diff)
libcamera: Enable vimc pipeline handler when tests are enabled
The addition of the new IPA IPC mechanism compiles pipeline-specific headers to define the interface between the pipeline and the IPA. This was optimised in 08ce394465b5 ("meson: ipa, proxy: Only build proxies for enabled pipelines") to only build for enabled pipelines, however the tests directly use the VIMC pipeline handler, and require it to be built. Create a local variable to store the requested pipelines from the user configuration and extend the enabled pipelines to ensure that VIMC is always enabled if the tests are also enabled Fixes: 08ce394465b5 ("meson: ipa, proxy: Only build proxies for enabled pipelines") Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Tested-by: Sebastian Fricke<sebastian.fricke@posteo.net>
Diffstat (limited to 'src/ipa/meson.build')
-rw-r--r--src/ipa/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/ipa/meson.build b/src/ipa/meson.build
index 9d623f22..df385eae 100644
--- a/src/ipa/meson.build
+++ b/src/ipa/meson.build
@@ -22,7 +22,7 @@ ipa_sign = files('ipa-sign.sh')
ipas = ['ipu3', 'raspberrypi', 'rkisp1', 'vimc']
ipa_names = []
-foreach pipeline : get_option('pipelines')
+foreach pipeline : pipelines
if ipas.contains(pipeline)
subdir(pipeline)
ipa_names += join_paths(ipa_install_dir, ipa_name + '.so')