summaryrefslogtreecommitdiff
path: root/src/ipa/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-09-15 04:11:01 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-09-15 13:58:21 +0300
commit4ec807192d9f1ef682e2c257cf4d832c35042305 (patch)
tree7132481f9991982951f48fff8fc42bbca37310ab /src/ipa/meson.build
parentba44276dd1393fb7583ac7253667c836a175158e (diff)
ipa: Generate the two dummy IPA modules from the same source
The ipa_dummy.cpp and ipa_dummy_isolate.cpp only differ in the license reported in the IPAModuleInfo structure. Drop the second file and generate the two .so from ipa_dummy.cpp, with the license defined through the command line. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'src/ipa/meson.build')
-rw-r--r--src/ipa/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/ipa/meson.build b/src/ipa/meson.build
index 2b9863bc..f09915bc 100644
--- a/src/ipa/meson.build
+++ b/src/ipa/meson.build
@@ -1,17 +1,17 @@
ipa_dummy_sources = [
- ['ipa_dummy', 'ipa_dummy.cpp'],
- ['ipa_dummy_isolate', 'ipa_dummy_isolate.cpp'],
+ ['ipa_dummy', 'LGPL-2.1-or-later'],
+ ['ipa_dummy_isolate', 'Proprietary'],
]
ipa_install_dir = join_paths(get_option('libdir'), 'libcamera')
foreach t : ipa_dummy_sources
- ipa = shared_module(t[0],
- t[1],
+ ipa = shared_module(t[0], 'ipa_dummy.cpp',
name_prefix : '',
include_directories : libcamera_includes,
install : true,
- install_dir : ipa_install_dir)
+ install_dir : ipa_install_dir,
+ cpp_args : '-DLICENSE="' + t[1] + '"')
endforeach
config_h.set('IPA_MODULE_DIR',