summaryrefslogtreecommitdiff
path: root/src/ipa/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2020-11-03 01:09:24 +0100
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2021-02-05 01:20:32 +0100
commit0a7000cc96ad26e01efc4b204d90ce3a9734ea06 (patch)
treeb9c40b792ce0a66fa34ebfc9b82306c756ffaf31 /src/ipa/meson.build
parentef8013767191da805caf81f30d7219863beae7d9 (diff)
libcamera: ipa: ipu3: Add an IPA skeleton for the IPU3 pipeline
Add an empty IPA skeleton for the IPU3 pipeline. The skeleton IPA handles the flow of parameter and statistic buffers but does not read or write anything in the buffers. It also allows the IPA to set sensor controls but does not implement any logic to set optimal values and instead sets the V4L2 exposure and gain controls to max and keeps them at that setting. This IPA is meant as a base to allow the pipeline handler to be wired up to an IPA. The image algorithms can then later be added to the IPA independently from also having to add plumbing to the pipeline handler. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/ipa/meson.build')
-rw-r--r--src/ipa/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/ipa/meson.build b/src/ipa/meson.build
index 5a5de267..9d623f22 100644
--- a/src/ipa/meson.build
+++ b/src/ipa/meson.build
@@ -19,7 +19,7 @@ subdir('libipa')
ipa_sign = files('ipa-sign.sh')
-ipas = ['raspberrypi', 'rkisp1', 'vimc']
+ipas = ['ipu3', 'raspberrypi', 'rkisp1', 'vimc']
ipa_names = []
foreach pipeline : get_option('pipelines')