summaryrefslogtreecommitdiff
path: root/src/ipa/libipa/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2024-06-14 20:37:56 +0900
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2024-06-17 12:18:51 +0300
commitf1959b9f313a33600eda575f32bbd06143a0cc45 (patch)
tree754ec8230040e0071392382d42da43d0bf10deb7 /src/ipa/libipa/meson.build
parentf191c10fe180fefac418fa41a3c49f5b18f9a3d7 (diff)
ipa: libipa: Add MatrixInterpolator class
Add a class to encapsulate the functionality of fetching a matrix based on an integer key, and interpolating if there is no exact match. This is expected to be used by both color correction matrices / crosstalk correction as well as lens shading correction. A cache is included only for exact matches of the key. The caller is expected to decide the tolererance for rounding. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Stefan Klug <stefan.klug@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/ipa/libipa/meson.build')
-rw-r--r--src/ipa/libipa/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/ipa/libipa/meson.build b/src/ipa/libipa/meson.build
index 1952dccf..eff8ce26 100644
--- a/src/ipa/libipa/meson.build
+++ b/src/ipa/libipa/meson.build
@@ -8,6 +8,7 @@ libipa_headers = files([
'fc_queue.h',
'histogram.h',
'matrix.h',
+ 'matrix_interpolator.h',
'module.h',
'pwl.h',
'vector.h',
@@ -21,6 +22,7 @@ libipa_sources = files([
'fc_queue.cpp',
'histogram.cpp',
'matrix.cpp',
+ 'matrix_interpolator.cpp',
'module.cpp',
'pwl.cpp',
'vector.cpp',