summaryrefslogtreecommitdiff
path: root/src/ipa/libipa/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2019-09-15 17:30:26 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-11-20 21:48:00 +0200
commit132d99bc8fac63d7473de6f62f7860b149f8e1c2 (patch)
treef6fbcb6ff234eaf3c44b71eed1c8215b736fc3c5 /src/ipa/libipa/meson.build
parentbc9527de454670445a8d69b039e65c0e5c7a699e (diff)
ipa: Switch to the plain C API
Switch IPA communication to the plain C API. As the IPAInterface class is easier to use for pipeline handlers than a plain C API, retain it and add an IPAContextWrapper that translate between the C++ and the C APIs. On the IPA module side usage of IPAInterface may be desired for IPAs implemented in C++ that want to link to libcamera. For those IPAs, a new IPAInterfaceWrapper helper class is introduced to wrap the IPAInterface implemented internally by the IPA module into an ipa_context, ipa_context_ops and ipa_callback_ops. Signed-off-by: Jacopo Mondi <jacopo@jmondi.org> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'src/ipa/libipa/meson.build')
-rw-r--r--src/ipa/libipa/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/ipa/libipa/meson.build b/src/ipa/libipa/meson.build
new file mode 100644
index 00000000..6f3cd486
--- /dev/null
+++ b/src/ipa/libipa/meson.build
@@ -0,0 +1,13 @@
+libipa_headers = files([
+ 'ipa_interface_wrapper.h',
+])
+
+libipa_sources = files([
+ 'ipa_interface_wrapper.cpp',
+])
+
+libipa_includes = include_directories('..')
+
+libipa = static_library('ipa', libipa_sources,
+ include_directories : ipa_includes,
+ dependencies : libcamera_dep)