summaryrefslogtreecommitdiff
path: root/src/ipa/ipu3/algorithms/meson.build
diff options
context:
space:
mode:
authorJean-Michel Hautbois <jeanmichel.hautbois@ideasonboard.com>2021-08-18 17:54:03 +0200
committerJean-Michel Hautbois <jeanmichel.hautbois@ideasonboard.com>2021-08-20 12:11:29 +0200
commit93802f600cf4c3bf15c9d044b980927615e800f4 (patch)
tree0f8415569586240b89560b59984052598f4e38cb /src/ipa/ipu3/algorithms/meson.build
parentb145ae42428b9f21fff01d7353a655e07e818c33 (diff)
ipa: ipu3: Move IPU3 agc into algorithms
Now that the interface is properly used by the AGC class, move it into ipa::ipu3::algorithms and let the loops do the calls. As we need to exchange the exposure_ and gain_ by passing them through the FrameContext, use the calculated values in setControls() function to ease the reading. Signed-off-by: Jean-Michel Hautbois <jeanmichel.hautbois@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/ipa/ipu3/algorithms/meson.build')
-rw-r--r--src/ipa/ipu3/algorithms/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipa/ipu3/algorithms/meson.build b/src/ipa/ipu3/algorithms/meson.build
index fa004df4..deae225b 100644
--- a/src/ipa/ipu3/algorithms/meson.build
+++ b/src/ipa/ipu3/algorithms/meson.build
@@ -1,6 +1,7 @@
# SPDX-License-Identifier: CC0-1.0
ipu3_ipa_algorithms = files([
+ 'agc.cpp',
'algorithm.cpp',
'awb.cpp',
'tone_mapping.cpp',