summaryrefslogtreecommitdiff
path: root/src/gstreamer/meson.build
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2020-01-25 17:47:17 -0500
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-03-07 01:58:07 +0200
commitbde275408c7f614ccf6e440bdd747f7b663fafe6 (patch)
treef02635a9338550ba454583678636020793e25bc7 /src/gstreamer/meson.build
parentd343326d28dd03877dd3d602c5494b5887ac34e5 (diff)
gst: Add a pool and an allocator implementation
This is needed to track the lifetime of the FrameBufferAllocator in relation to the GstBuffer/GstMemory objects travelling inside GStreamer. Signed-off-by: Nicolas Dufresne <nicolas.dufresne@collabora.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/gstreamer/meson.build')
-rw-r--r--src/gstreamer/meson.build13
1 files changed, 9 insertions, 4 deletions
diff --git a/src/gstreamer/meson.build b/src/gstreamer/meson.build
index 5324b2f5..1965b504 100644
--- a/src/gstreamer/meson.build
+++ b/src/gstreamer/meson.build
@@ -1,7 +1,9 @@
libcamera_gst_sources = [
'gstlibcamera-utils.cpp',
'gstlibcamera.c',
+ 'gstlibcameraallocator.cpp',
'gstlibcamerapad.cpp',
+ 'gstlibcamerapool.cpp',
'gstlibcameraprovider.cpp',
'gstlibcamerasrc.cpp',
]
@@ -13,10 +15,13 @@ libcamera_gst_c_args = [
glib_dep = dependency('glib', required : get_option('gstreamer'))
-gst_dep = dependency('gstreamer-video-1.0', version : '>=1.14.0',
- required : get_option('gstreamer'))
+gst_dep_version = '>=1.14.0'
+gstvideo_dep = dependency('gstreamer-video-1.0', version : gst_dep_version,
+ required : get_option('gstreamer'))
+gstallocator_dep = dependency('gstreamer-allocators-1.0', version : gst_dep_version,
+ required : get_option('gstreamer'))
-if glib_dep.found() and gst_dep.found()
+if glib_dep.found() and gstvideo_dep.found() and gstallocator_dep.found()
# The G_DECLARE_FINAL_TYPE macro creates static inline functions that were
# not marked as possibly unused prior to GLib v2.63.0. This causes clang to
# complain about the ones we are not using. Silence the -Wunused-function
@@ -28,7 +33,7 @@ if glib_dep.found() and gst_dep.found()
libcamera_gst = shared_library('gstlibcamera',
libcamera_gst_sources,
c_args : libcamera_gst_c_args,
- dependencies : [libcamera_dep, gst_dep],
+ dependencies : [libcamera_dep, gstvideo_dep, gstallocator_dep],
install: true,
install_dir : '@0@/gstreamer-1.0'.format(get_option('libdir')),
)