summaryrefslogtreecommitdiff
path: root/src/gstreamer/meson.build
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2020-01-14 13:37:57 -0500
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-03-07 01:57:45 +0200
commit71a28f959313c573097fa23d5894b0104f092352 (patch)
tree9f63836911be6603d3958587da31dd185508a247 /src/gstreamer/meson.build
parent7e82d3c2a1ecca4f2041a1a095a0725fe9d172c0 (diff)
gst: Add pads to the source
This simply adds the boiler plate for pads on the source element. The design is that we have one pad, called "src", that will always be present, and then more pads can be requested prior in READY or less state. Initially pads have one property "stream-role" that let you decide which role this pad will have. Signed-off-by: Nicolas Dufresne <nicolas.dufresne@collabora.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/gstreamer/meson.build')
-rw-r--r--src/gstreamer/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/gstreamer/meson.build b/src/gstreamer/meson.build
index 7e26e3e1..5324b2f5 100644
--- a/src/gstreamer/meson.build
+++ b/src/gstreamer/meson.build
@@ -1,6 +1,7 @@
libcamera_gst_sources = [
'gstlibcamera-utils.cpp',
'gstlibcamera.c',
+ 'gstlibcamerapad.cpp',
'gstlibcameraprovider.cpp',
'gstlibcamerasrc.cpp',
]