summaryrefslogtreecommitdiff
path: root/src/gstreamer/meson.build
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2020-01-09 14:31:18 -0500
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-03-07 01:57:45 +0200
commit0e0cc2149ec10f6bad74a646ce3eaeba7f6c5b54 (patch)
treef72d96ffc84dd852a1bd85570c623f42f6ecb80d /src/gstreamer/meson.build
parenteee8f56f0a7f34574752948027843bf6a1912e90 (diff)
gst: Add initial device provider
This feature is used with GstDeviceMonitor in order to enumerate and monitor devices to be used with the source element. The resulting GstDevice implementation is also used by application to abstract the configuration of the source element. Implementation notes: - libcamera does not support polling yet - The device ID isn't unique in libcamera yet - The "name" property does not yet exist in libcamerasrc yet Signed-off-by: Nicolas Dufresne <nicolas.dufresne@collabora.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/gstreamer/meson.build')
-rw-r--r--src/gstreamer/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/gstreamer/meson.build b/src/gstreamer/meson.build
index 9b11a46f..7e26e3e1 100644
--- a/src/gstreamer/meson.build
+++ b/src/gstreamer/meson.build
@@ -1,6 +1,7 @@
libcamera_gst_sources = [
'gstlibcamera-utils.cpp',
'gstlibcamera.c',
+ 'gstlibcameraprovider.cpp',
'gstlibcamerasrc.cpp',
]