summaryrefslogtreecommitdiff
path: root/src/cam/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2022-05-18 19:19:17 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-05-22 12:52:02 +0300
commit38bff0c82bf18e7bc7a35a5395ccdc8078797f30 (patch)
treeb132ebb007e8b76567a1710980ac17af10874a4a /src/cam/meson.build
parent0c1b3f5e4c5f36c19d702529d4b597415f813394 (diff)
cam: Add a parser for capture scripts
Add a parser class to the cam test application to control the capture operations through a yaml script. The capture script currently allow to specify a list of controls and their associated values to be applied per-frame. Also add a trivial capture script example to showcase the intended script structure. Signed-off-by: Jacopo Mondi <jacopo@jmondi.org> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'src/cam/meson.build')
-rw-r--r--src/cam/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/cam/meson.build b/src/cam/meson.build
index 5bab8c9e..c47a8559 100644
--- a/src/cam/meson.build
+++ b/src/cam/meson.build
@@ -11,6 +11,7 @@ cam_enabled = true
cam_sources = files([
'camera_session.cpp',
+ 'capture_script.cpp',
'event_loop.cpp',
'file_sink.cpp',
'frame_sink.cpp',
@@ -38,6 +39,7 @@ cam = executable('cam', cam_sources,
libcamera_public,
libdrm,
libevent,
+ libyaml,
],
cpp_args : cam_cpp_args,
install : true)