summaryrefslogtreecommitdiff
path: root/src/cam/meson.build
diff options
context:
space:
mode:
authorEric Curtin <ecurtin@redhat.com>2022-05-20 20:01:05 +0100
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-05-23 12:49:44 +0300
commit11554a259f4e8df3cc2ddce0217d35fd7797cfc5 (patch)
tree935bde6e6a369ee13a5814753c8b525a9ccb8306 /src/cam/meson.build
parenta5844adb7b6b564f77fb15ec0716ac85bcb1bc42 (diff)
cam: sdl_sink: Add SDL sink with initial YUYV support
This adds more portability to existing cam sinks. You can pass a YUYV camera buffer and SDL will handle the pixel buffer conversion to the display. This allows cam reference implementation to display images on VMs, Mac M1, Raspberry Pi, etc. This also enables cam reference implementation, to run as a desktop application in Wayland or X11. SDL also has support for Android and ChromeOS which has not been tested. Also tested on simpledrm Raspberry Pi 4 framebuffer successfully where existing kms sink did not work. Can also be used as kmsdrm sink. Only supports one camera stream at present. Signed-off-by: Eric Curtin <ecurtin@redhat.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Tested-by: Jacopo Mondi <jacopo@jmondi.org> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/cam/meson.build')
-rw-r--r--src/cam/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/cam/meson.build b/src/cam/meson.build
index c47a8559..c17a971f 100644
--- a/src/cam/meson.build
+++ b/src/cam/meson.build
@@ -24,6 +24,7 @@ cam_sources = files([
cam_cpp_args = []
libdrm = dependency('libdrm', required : false)
+libsdl2 = dependency('SDL2', required : false)
if libdrm.found()
cam_cpp_args += [ '-DHAVE_KMS' ]
@@ -33,12 +34,22 @@ if libdrm.found()
])
endif
+if libsdl2.found()
+ cam_cpp_args += ['-DHAVE_SDL']
+ cam_sources += files([
+ 'sdl_sink.cpp',
+ 'sdl_texture.cpp',
+ 'sdl_texture_yuyv.cpp'
+ ])
+endif
+
cam = executable('cam', cam_sources,
dependencies : [
libatomic,
libcamera_public,
libdrm,
libevent,
+ libsdl2,
libyaml,
],
cpp_args : cam_cpp_args,