summaryrefslogtreecommitdiff
path: root/src/apps/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-10-20 01:11:57 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-10-20 13:36:26 +0300
commitcd5439fb97518d8bce0eb2af3f9562d6fd593acf (patch)
treec161f8f4c1f65d89c5a30f5613941e993aeb56b9 /src/apps/meson.build
parent84ad104499d9efc0253dae1a60ee070ed375ad95 (diff)
apps: Move libevent dependency to src/apps/meson.build
libevent is a shared dependency between cam and lc-compliance, move it to src/apps/. The shared dependency will be used to condition compilation of source files in an upcoming application static library. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/apps/meson.build')
-rw-r--r--src/apps/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/apps/meson.build b/src/apps/meson.build
index 9e4388bd..62cff67e 100644
--- a/src/apps/meson.build
+++ b/src/apps/meson.build
@@ -1,5 +1,15 @@
# SPDX-License-Identifier: CC0-1.0
+opt_cam = get_option('cam')
+opt_lc_compliance = get_option('lc-compliance')
+
+# libevent is needed by cam and lc-compliance. As they are both feature options,
+# they can't be combined with simple boolean logic.
+libevent = dependency('libevent_pthreads', required : opt_cam)
+if not libevent.found()
+ libevent = dependency('libevent_pthreads', required : opt_lc_compliance)
+endif
+
subdir('lc-compliance')
subdir('cam')