summaryrefslogtreecommitdiff
path: root/src/android/mm/meson.build
diff options
context:
space:
mode:
authorHirokazu Honda <hiroh@chromium.org>2021-11-24 03:39:47 +0900
committerJacopo Mondi <jacopo@jmondi.org>2021-12-06 17:41:45 +0100
commitc58662c5770e4c2b4446318295055fcbc04c1824 (patch)
tree1cd386867a7f825cba50f95f4f52239ebd2b6638 /src/android/mm/meson.build
parent99bb610fd1b270f126a6b35c0231843973d8f35b (diff)
android: Introduce PlatformFrameBufferAllocator
The existing FrameBufferAllocator is not allowed to allocate a new buffer while Camera is running. This introduces PlatformFrameBufferAllocator. It allocates FrameBuffer using cros::CameraBufferManager on ChromeOS and gralloc on non ChromeOS platform. The allocated FrameBuffer owns the underlying buffer but must be destroyed before PlatformFrameBufferAllocator is destroyed. Signed-off-by: Hirokazu Honda <hiroh@chromium.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org> Signed-off-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'src/android/mm/meson.build')
-rw-r--r--src/android/mm/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/android/mm/meson.build b/src/android/mm/meson.build
index eeb5cc2e..d40a3b0b 100644
--- a/src/android/mm/meson.build
+++ b/src/android/mm/meson.build
@@ -2,8 +2,10 @@
platform = get_option('android_platform')
if platform == 'generic'
- android_hal_sources += files(['generic_camera_buffer.cpp'])
+ android_hal_sources += files(['generic_camera_buffer.cpp',
+ 'generic_frame_buffer_allocator.cpp'])
elif platform == 'cros'
- android_hal_sources += files(['cros_camera_buffer.cpp'])
+ android_hal_sources += files(['cros_camera_buffer.cpp',
+ 'cros_frame_buffer_allocator.cpp'])
android_deps += [dependency('libcros_camera')]
endif