summaryrefslogtreecommitdiff
path: root/src/android/mm/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2021-02-17 16:04:34 +0100
committerJacopo Mondi <jacopo@jmondi.org>2021-03-03 09:50:12 +0100
commit64c17f73a08fd121c233e655d6ded9790c03dda5 (patch)
treeec797bd5c44c79a362ad5f6787f56b31ebaed09a /src/android/mm/meson.build
parentad9eee2a7d91cd6113242194b8bc7be905436cb5 (diff)
android: Introduce CameraBuffer interface
In order to provide support for different memory backends, move the MappedCamera3Buffer class definition outside of the CameraDevice class to its own file and rename it in CameraBuffer. The interface defined in camera_buffer.h will be implemented by different backends that will be placed in the src/android/mm subdirectory. Provide a first implementation for the 'generic android' backend which matches the existing one. Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'src/android/mm/meson.build')
-rw-r--r--src/android/mm/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/android/mm/meson.build b/src/android/mm/meson.build
new file mode 100644
index 00000000..97f83f2a
--- /dev/null
+++ b/src/android/mm/meson.build
@@ -0,0 +1,6 @@
+# SPDX-License-Identifier: CC0-1.0
+
+platform = get_option('android_platform')
+if platform == 'generic'
+ android_hal_sources += files(['generic_camera_buffer.cpp'])
+endif