summaryrefslogtreecommitdiff
path: root/src/android/meson.build
diff options
context:
space:
mode:
authorUmang Jain <email@uajain.com>2020-10-16 11:07:54 +0530
committerKieran Bingham <kieran.bingham@ideasonboard.com>2020-10-16 10:23:10 +0100
commitb2b8c4dc941b979ddf5e9013530e76c67e6a12fe (patch)
tree3eaeb0150a536b18619a14bcdfa16a771104ee29 /src/android/meson.build
parent3d946a2e609ced0331563558e120361f153ef442 (diff)
android: jpeg: Port to PostProcessor interface
Port the CameraStream's JPEG-encoding bits to PostProcessorJpeg. This encapsulates the encoder and EXIF generation code into the PostProcessorJpeg layer and removes these specifics related to JPEG, from the CameraStream itself. Signed-off-by: Umang Jain <email@uajain.com> Tested-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Change-Id: Id9e6e9b2bec83493a90e5e126298a2bb2ed2232a
Diffstat (limited to 'src/android/meson.build')
-rw-r--r--src/android/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/android/meson.build b/src/android/meson.build
index b2b2293c..5a01bea3 100644
--- a/src/android/meson.build
+++ b/src/android/meson.build
@@ -24,6 +24,7 @@ android_hal_sources = files([
'camera_worker.cpp',
'jpeg/encoder_libjpeg.cpp',
'jpeg/exif.cpp',
+ 'jpeg/post_processor_jpeg.cpp',
])
android_camera_metadata_sources = files([