summaryrefslogtreecommitdiff
path: root/src/android/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2019-05-10 17:45:11 +0200
committerJacopo Mondi <jacopo@jmondi.org>2019-08-12 10:34:13 +0200
commit552b5d16d782eb437a5db13472978cd0ce70dd46 (patch)
tree0fe89056ec9bc4ba57d6f6f6eec18c240d612d01 /src/android/meson.build
parent190bebef0840e7c987ac749ae48ffcb3547a03a2 (diff)
android: Add camera metadata library
Import the Android camera metadata library from the ChromiumOS build system. The camera metadata library has been copied from https://chromium.googlesource.com/chromiumos/platform2 at revision 9e65ddd2c496e712f005ada9715decd2ff8e4a03 The original path in the Cros platform2/ repository is: camera/android/libcamera_metadata/src Create a new build target for the camera metadata library to create a static library to link against libcamera. Signed-off-by: Jacopo Mondi <jacopo@jmondi.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/android/meson.build')
-rw-r--r--src/android/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/android/meson.build b/src/android/meson.build
new file mode 100644
index 00000000..1f242953
--- /dev/null
+++ b/src/android/meson.build
@@ -0,0 +1,7 @@
+android_camera_metadata_sources = files([
+ 'metadata/camera_metadata.c',
+])
+
+android_camera_metadata = static_library('camera_metadata',
+ android_camera_metadata_sources,
+ include_directories : android_includes)