summaryrefslogtreecommitdiff
path: root/src/android/meson.build
diff options
context:
space:
mode:
authorUmang Jain <umang.jain@ideasonboard.com>2021-10-19 17:17:51 +0530
committerUmang Jain <umang.jain@ideasonboard.com>2021-10-19 19:14:53 +0530
commit109a98e8c07b57a4676bf62dbba59cba670163c8 (patch)
tree4f0be90c8d21265cd12e7dadb3ea5be3f0d4ea4a /src/android/meson.build
parentdb39cc76982b8d5e4732c25e46774f988d3df377 (diff)
camera_device: Remove private scope of Camera3RequestDescriptor
Camera3RequestDescriptor is a utility structure that groups information about a capture request. It can be and will be extended to preserve the context of a capture overall. Since the context of a capture needs to be shared among other classes (for e.g. CameraStream) having a private definition of the struct in CameraDevice class doesn't help. Hence, de-scope the structure so that it can be shared with other components (through references or pointers). Splitting the structure to a separate file will help avoiding circular dependencies when using it through the HAL implementation. Signed-off-by: Umang Jain <umang.jain@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org> Reviewed-by: Hirokazu Honda <hiroh@chromium.org>
Diffstat (limited to 'src/android/meson.build')
-rw-r--r--src/android/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/android/meson.build b/src/android/meson.build
index 7d1e7e85..332b177c 100644
--- a/src/android/meson.build
+++ b/src/android/meson.build
@@ -45,6 +45,7 @@ android_hal_sources = files([
'camera_hal_manager.cpp',
'camera_metadata.cpp',
'camera_ops.cpp',
+ 'camera_request.cpp',
'camera_stream.cpp',
'camera_worker.cpp',
'jpeg/encoder_libjpeg.cpp',