summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-04-27 05:12:18 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-04-27 17:11:13 +0300
commitdf587aa10005475a1a9300001e7045b1ba357b9e (patch)
tree1be5ca2343d9823ba2c807907817a7456a621fc8 /meson.build
parentc34e09d33a6d81e1bbe818a8e652e0c60de50982 (diff)
libcamera: Make libudev optional
libcamera depends on libudev for device enumeration. It is however useful to allow building documentation without requiring the dependency to be installed. Make the libudev dependency optional and compile the udev-based device enumerator out when libudev is not present. Note that while libcamera will compile without libudev, it will not be able to enumerate devices. A sysfs-based device enumerator is planned as a fallback but not implemented yet. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3434dd7c..d272ff33 100644
--- a/meson.build
+++ b/meson.build
@@ -19,7 +19,6 @@ config_h = configuration_data()
if cc.has_header_symbol('stdlib.h', 'secure_getenv', prefix: '#define _GNU_SOURCE')
config_h.set('HAVE_SECURE_GETENV', 1)
endif
-configure_file(output: 'config.h', configuration: config_h)
common_arguments = [
'-Wno-unused-parameter',
@@ -49,6 +48,8 @@ if get_option('tests')
subdir('test')
endif
+configure_file(output: 'config.h', configuration: config_h)
+
pkg_mod = import('pkgconfig')
pkg_mod.generate(libraries : libcamera,
version : '1.0',