summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNaushir Patuck <naush@raspberrypi.com>2021-10-18 10:29:42 +0100
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-10-19 13:14:54 +0300
commitdb39cc76982b8d5e4732c25e46774f988d3df377 (patch)
tree009cf32a89f824e0fbb32e6db864107738a377c6 /meson.build
parent54637a615dcdac20f1f61a017d3bae429aa389e4 (diff)
build: Preserve upstream git versioning using meson dist
When distributions build and package libcamera libraries, they may not necessarily run the build in the upstream source tree. In these cases, the git SHA1 versioning information will be lost. This change addresses that problem by requiring package managers to run 'meson dist' to create a tarball of the source files and build from there. On runing 'meson dist', the utils/run-dist.sh script will create a .tarball-version file in the release tarball with the version string generated from the existing utils/gen-version.sh script. The utils/gen-version.sh script has been updated to check for the presence of this .tarball-version file and read the version string from it instead of creating one. Signed-off-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index bd3246eb..7892a9e3 100644
--- a/meson.build
+++ b/meson.build
@@ -25,6 +25,9 @@ endif
libcamera_version = libcamera_git_version.split('+')[0]
+# This script gererates the .tarball-version file on a 'meson dist' command.
+meson.add_dist_script('utils/run-dist.sh')
+
# Configure the build environment.
cc = meson.get_compiler('c')
cxx = meson.get_compiler('cpp')