summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2020-09-09 11:47:11 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2020-09-24 10:55:39 +0100
commitd6b6ad950d73b21dd6dc58ddedd4c2cfd4b638ef (patch)
treee021bd07caf28181f40f978f136273a3ecd94a5c /meson.build
parentf999ee85faacb097b7ce173a8704816e388dbfe9 (diff)
meson: Process utils first
The utils directory can contain helpers and support tools which are used throughout other components of the build. Ensure that the utils subdir is parsed first allowing helpers to be defined there. Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c58d458c..dd71390b 100644
--- a/meson.build
+++ b/meson.build
@@ -101,9 +101,11 @@ add_project_link_arguments(cpp_arguments, language : 'cpp')
libcamera_includes = include_directories('include')
+# Utilities are parsed first to provide support for other components.
+subdir('utils')
+
subdir('include')
subdir('src')
-subdir('utils')
# The documentation and test components are optional and can be disabled
# through configuration values. They are enabled by default.