summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2018-11-20 08:18:42 -0800
committerKieran Bingham <kieran.bingham@ideasonboard.com>2018-11-28 11:10:11 +0000
commitc60069241f5ebd7c3a024435171efc58f3d01522 (patch)
treefcab18f3daad55b71fddc5c7f61b24d28ec9672e /meson.build
parentce1c86c10cba48a1acc9b7ee745efb383077711a (diff)
Documentation: Introduce sphinx documentation
Utilise sphinx-build to generate documentation in HTML form, and populate with some initial content. An initial conf.py is generated from sphinx-quickstart and answering initial questions. Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 17767b9e..1e2bf956 100644
--- a/meson.build
+++ b/meson.build
@@ -2,6 +2,11 @@ project('libcamera - supporting complex camera pipelines', 'c', 'cpp',
version : '0.1',
license : 'LGPL 2.1+')
+# TODO: Extract this from project.version.
+# Ideally the version at Documentation/conf.py should be
+# generated from this too.
+api_version = '0.1'
+
common_arguments = [
'-Wall',
'-Wextra',
@@ -17,6 +22,7 @@ add_project_arguments(cpp_arguments, language: 'cpp')
inc = include_directories('include')
+subdir('Documentation')
subdir('include')
subdir('lib')
subdir('test')