summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-09-24 04:39:58 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-10-15 05:05:20 +0300
commitbae9d2bdb32ee8cdc717537ae498eee03a25543b (patch)
treec582f59b5bf2a00363d17e4982f64997b9a4ce29 /meson.build
parentca5fb994091e7b3ba6db484ae0a58e2ecd00abbf (diff)
libcamera: base: Add Backtrace class
Create a new class to abstract generation and access to call stack backtraces. The current implementation depends on the glibc backtrace() implementation and is copied from the logger. Future development will bring support for libunwind, transparently for the users of the class. The logger backtrace implementation is dropped, replaced by usage of the new Backtrace class. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 0 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index a49c484f..dfed01ba 100644
--- a/meson.build
+++ b/meson.build
@@ -29,10 +29,6 @@ cc = meson.get_compiler('c')
cxx = meson.get_compiler('cpp')
config_h = configuration_data()
-if cc.has_header_symbol('execinfo.h', 'backtrace')
- config_h.set('HAVE_BACKTRACE', 1)
-endif
-
if cc.has_header_symbol('unistd.h', 'issetugid')
config_h.set('HAVE_ISSETUGID', 1)
endif