summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-03-20 23:39:21 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-03-28 01:47:26 +0200
commitb68721608ac4370564a41f1cc3aaa61a13d363cf (patch)
tree662eaa24f6d772eb3a6d8c3afe30fb053a15325e /meson.build
parent1456efe7d51a3a0c6b57db4310f75b2a08ab1756 (diff)
meson: Summarize which applications and adaptation layers are built
Add the application and adaptation layers being built to the meson summary. The summary now prints libcamera 0.0.0 Configuration Enabled pipelines: ipu3 raspberrypi rkisp1 simple uvcvideo vimc Android support: True GStreamer support: True V4L2 emulation support: True cam application: True qcam application: True Unit tests: True Subprojects libyuv: YES Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Hirokazu Honda <hiroh@chromium.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1768f6ea..3a615ae3 100644
--- a/meson.build
+++ b/meson.build
@@ -168,4 +168,10 @@ py_mod.find_installation('python3', modules: py_modules)
## Summarise Configurations
summary({
'Enabled pipelines': pipelines,
+ 'Android support': android_enabled,
+ 'GStreamer support': gst_enabled,
+ 'V4L2 emulation support': v4l2_enabled,
+ 'cam application': cam_enabled,
+ 'qcam application': qcam_enabled,
+ 'Unit tests': test_enabled,
}, section : 'Configuration')