summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEzequiel Garcia <ezequiel@collabora.com>2019-11-20 08:45:49 -0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-09-24 21:08:40 +0300
commitaac96e34ba73a2dd63a12be446fe8db3c04db12f (patch)
tree011d7233219b8b503fb7e2374477abb70ef934aa /meson.build
parentda81e368e7724979d8e64c53a5a983deb9ab021a (diff)
meson: Define python3 and python3-yaml required dependencies
With this change, meson will complain specifically about missing python3 and missing python3-yaml. As specified by meson documentation: https://mesonbuild.com/Python-module.html, this change requires meson v0.51. Signed-off-by: Ezequiel Garcia <ezequiel@collabora.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 020ea93c..dd88eead 100644
--- a/meson.build
+++ b/meson.build
@@ -101,6 +101,9 @@ add_project_link_arguments(cpp_arguments, language : 'cpp')
libcamera_includes = include_directories('include')
+# Sub-directories fill py_modules with their dependencies.
+py_modules = []
+
# Utilities are parsed first to provide support for other components.
subdir('utils')
@@ -143,5 +146,9 @@ pkg_mod.generate(libraries : libcamera,
description : 'Complex Camera Support Library',
subdirs : 'libcamera')
+# Check for python installation and modules.
+py_mod = import('python')
+py_mod.find_installation('python3', modules: py_modules)
+
## Summarise Configurations
message('Enabled pipelines: ' + ', '.join(get_option('pipelines')))