summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-02-21 15:57:02 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-02-22 10:04:12 +0200
commita7ab5ef1d2f9b05056db450e631a99a73382d589 (patch)
treeb6e4603484b957f878045b198a536a1d71c419f2 /meson.build
parent7a118dbdb881c38ad13de12efb023c6b78d2a57e (diff)
libcamera: Require gcc 8 or newer
gcc 7 has reached end of life and isn't used as a default compiler by any of the major distributions. It has also been dropped from buildroot. Drop its support in libcamera. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 5 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 9684d562..29d8542d 100644
--- a/meson.build
+++ b/meson.build
@@ -81,11 +81,11 @@ if cc.get_id() == 'clang'
endif
if cc.get_id() == 'gcc'
- if cc.version().version_compare('<7')
- error('gcc version is too old, libcamera requires 7.0 or newer')
+ if cc.version().version_compare('<8')
+ error('gcc version is too old, libcamera requires 8.0 or newer')
endif
- # On gcc 7 and 8, the file system library is provided in a separate static
+ # On gcc 8, the file system library is provided in a separate static
# library.
if cc.version().version_compare('<9')
cpp_arguments += [
@@ -95,9 +95,8 @@ if cc.get_id() == 'gcc'
# gcc 7.1 introduced processor-specific ABI breakages related to parameter
# passing on ARM platforms. This generates a large number of messages
- # during compilation with gcc >=7.1. Silence them.
- if (host_machine.cpu_family() == 'arm' and
- cc.version().version_compare('>=7.1'))
+ # during compilation. Silence them.
+ if host_machine.cpu_family() == 'arm'
cpp_arguments += [
'-Wno-psabi',
]