summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2018-11-26 14:22:14 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2018-11-27 12:11:48 +0000
commita66fe04c1949328101ed8bdbf0274b89d0f03c16 (patch)
tree9aa396a510aaa133b61bde065b4a7a71964cd5ff /meson.build
parent66051636c5754a33a812d9f306935e29397e0009 (diff)
build: Add project arguments
Add language specific project arguments and ensure that -Werror is enabled, enforcing code to be as clean as possible. Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1f57b49d..17767b9e 100644
--- a/meson.build
+++ b/meson.build
@@ -2,6 +2,19 @@ project('libcamera - supporting complex camera pipelines', 'c', 'cpp',
version : '0.1',
license : 'LGPL 2.1+')
+common_arguments = [
+ '-Wall',
+ '-Wextra',
+ '-Werror',
+ '-Wno-unused-parameter',
+]
+
+c_arguments = common_arguments
+cpp_arguments = common_arguments
+
+add_project_arguments(c_arguments, language: 'c')
+add_project_arguments(cpp_arguments, language: 'cpp')
+
inc = include_directories('include')
subdir('include')