summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2020-07-28 12:18:11 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2020-10-21 17:18:49 +0100
commit9f567cc140bdbd7dc1db8efa76cd93862000c218 (patch)
tree7a75af4982fff6d76669c76308f975a875b5a02c /meson.build
parente6278e057170b83415d95824ccb24779a4f9431f (diff)
meson: Enable shadowed variable warning
Shadowing variables can lead to unexpected bugs where a code path utilises a variable that may not have been intended by the developer, leading to hard to find bugs. Enable warnings for shadowed variables as defined at: https://gcc.gnu.org/onlinedocs/gcc/Warning-Options.html#index-Wshadow As an effect of utilising -Werror, this will cause variable or type shadowing to become a build-time error. Suggested-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b0c17d3e..e6f6c84a 100644
--- a/meson.build
+++ b/meson.build
@@ -38,6 +38,7 @@ if cc.has_header_symbol('stdlib.h', 'secure_getenv', prefix : '#define _GNU_SOUR
endif
common_arguments = [
+ '-Wshadow',
'-include', 'config.h',
]