summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2019-03-20 15:44:08 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2019-03-20 16:27:30 +0000
commit945478dbc0198fed27ce885d3ec33c95c77bc69f (patch)
tree0a014efcd46415bd8a7f7e69dea81e6f3bb47fc9 /meson.build
parent651f6973a09d63bae816614b8d2e028a1c052cb3 (diff)
meson: Provide options to disable test/docs
It can be desirable to disable the compilation and processing of both the test suite and documentation for use cases such as packaging to an embedded target. Provide a new meson_options.txt file to allow disabling either or both of the tests and documentation components of libcamera. These options can be provided at the initial configuration time, for example: meson build -Dtests=false -Ddocumentation=false or by reconfiguring an existing build tree: cd build meson configure -Ddocumentation=false meson configure -Dtests=false Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 4465a385..43d4a576 100644
--- a/meson.build
+++ b/meson.build
@@ -27,9 +27,15 @@ libcamera_includes = include_directories('include')
subdir('include')
subdir('src')
-subdir('test')
subdir('utils')
-subdir('Documentation')
+
+if get_option('tests')
+ subdir('test')
+endif
+
+if get_option('documentation')
+ subdir('Documentation')
+endif
pkg_mod = import('pkgconfig')
pkg_mod.generate(libraries : libcamera,