summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-01-20 09:32:21 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-01-20 18:07:44 +0200
commit8e1e10283a4149a7a052c718f077a15aba2c1a64 (patch)
tree1e589a65bfdd0ff7378f88171534573181d891aa /meson.build
parent7b4ed981c71a0551dfb49dd9032c5d363761c2d8 (diff)
libcamera: Use meson summary() function to summarize configuration
Now that Debian backports have been updated to meson v0.56, all major distributions provide meson >= v0.53 in their latest LTS version. We can replace the manual message()-based configuration summary with the summary() function. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Sebastian Fricke <sebastian.fricke@posteo.net> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index c47eb420..743cb1d2 100644
--- a/meson.build
+++ b/meson.build
@@ -1,7 +1,7 @@
# SPDX-License-Identifier: CC0-1.0
project('libcamera', 'c', 'cpp',
- meson_version : '>= 0.51',
+ meson_version : '>= 0.53',
version : '0.0.0',
default_options : [
'werror=true',
@@ -155,4 +155,6 @@ py_mod = import('python')
py_mod.find_installation('python3', modules: py_modules)
## Summarise Configurations
-message('Enabled pipelines: ' + ', '.join(get_option('pipelines')))
+summary({
+ 'Enabled pipelines': get_option('pipelines'),
+ }, section : 'Configuration')