summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2023-05-01 12:38:12 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2023-07-04 20:25:10 +0100
commit8da938b00705c7bdc188174f45ee485d0880ee1e (patch)
tree1863ff283bca4560a2c45d081735aeba63b50225 /meson.build
parentbbb77cc59bfb71e5a125b0b54d6230dd6da8613d (diff)
meson: Use x.y soname versioning
Now that we identify ABI breakages, provide incremental releases which can support backwards compatible linkage across release points that have a compatible ABI. Introduction of this commit does not convey that libcamera now has a stable API, but that patch releases with a common minor number (0.minor.patch) may potentially be used by applications without recompilation and linkage against new releases. Reviewed-by: Umang Jain <umang.jain@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 4 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index e1fd9243..9c1e7081 100644
--- a/meson.build
+++ b/meson.build
@@ -56,15 +56,13 @@ if libcamera_version != project_version
libcamera_git_version += '-nvm'
endif
-# Until we make ABI compatible releases, the full libcamera version is used as
-# the soname. No ABI/API compatibility is guaranteed between releases (x.y.z).
-#
-# When automatic ABI based detection is used to increment the version, this
-# will bump the minor number (x.y).
+# The major and minor libcamera version components are used as the soname.
+# No ABI/API compatibility is guaranteed between releases (x.y).
#
# When we declare a stable ABI/API we will provide a 1.0 release and the
# soversion at that point will be the 'major' release value (x).
-libcamera_soversion = libcamera_version
+semver = libcamera_version.split('.')
+libcamera_soversion = semver[0] + '.' + semver[1]
summary({ 'Sources': libcamera_git_version, }, section : 'Versions')