summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2018-12-11 20:20:07 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2018-12-12 20:45:24 +0200
commit53c4d4c34fc49b95ca07265fc65940df9c365074 (patch)
tree46780761cc9034bb60dcda0a396fbd97e595eac3 /meson.build
parent652b1c8679c3b18e4dec11a923b53bf333451ed1 (diff)
Documentation: Generate source code documentation using Doxygen
Extend the documentation build system to automatically generate documentation from source code using Doxygen. This is currently separate from the sphinx documentation, and should be integrated using the breathe (and possibly exhale) extensions. As the Documentation/meson.build file needs to reference the variables holding the source files, move the Documentation directory to the end of the subdirs() in the top-level meson.build. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e6ed03f9..2fdb166c 100644
--- a/meson.build
+++ b/meson.build
@@ -23,11 +23,11 @@ add_project_arguments(cpp_arguments, language: 'cpp')
libcamera_includes = include_directories('include')
-subdir('Documentation')
subdir('include')
subdir('src')
subdir('test')
subdir('utils')
+subdir('Documentation')
pkg_mod = import('pkgconfig')
pkg_mod.generate(libraries : libcamera,