summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2019-03-22 09:26:12 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2019-04-03 11:44:04 +0700
commit4635df70063980f87c7c74567eea58b2195091d7 (patch)
tree964d39f3d36cfae1746aeba87f7a232f8e03a591 /meson.build
parent80e236e19b61a1267948433fd6855da138d6f527 (diff)
meson: Re-order the optional components
Re-order the optional components to make them alphabetical, and fix up the indentation to use two spaces as required by meson. A comment is added to highlight that these optional components are enabled by default. Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 7 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 43d4a576..6e68c3e3 100644
--- a/meson.build
+++ b/meson.build
@@ -29,12 +29,15 @@ subdir('include')
subdir('src')
subdir('utils')
-if get_option('tests')
- subdir('test')
-endif
+# The documentation and test components are optional and can be disabled
+# through configuration values. They are enabled by default.
if get_option('documentation')
- subdir('Documentation')
+ subdir('Documentation')
+endif
+
+if get_option('tests')
+ subdir('test')
endif
pkg_mod = import('pkgconfig')