summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-05-23 00:05:30 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-05-23 11:55:45 +0300
commit41adc3f8d39e78eb432bf33ab859d1f5429b85dc (patch)
treef637a6b1e28b2dbb0ebce1274bebef1a8ac678ff /meson.build
parent1f32abb995a04b7c67af6d923fea82436e817de1 (diff)
meson: Fix coding style in meson.build files
Consistently go for 4 spaces indentation, and always put a space between the colon in argument lists, as per the examples from the meson documentation. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build28
1 files changed, 14 insertions, 14 deletions
diff --git a/meson.build b/meson.build
index d272ff33..4d3e99d3 100644
--- a/meson.build
+++ b/meson.build
@@ -1,12 +1,12 @@
project('libcamera', 'c', 'cpp',
- meson_version: '>= 0.40',
- version : '0.1',
- default_options: [
- 'werror=true',
- 'warning_level=2',
- 'cpp_std=c++11',
- ],
- license : 'LGPL 2.1+')
+ meson_version : '>= 0.40',
+ version : '0.1',
+ default_options : [
+ 'werror=true',
+ 'warning_level=2',
+ 'cpp_std=c++11',
+ ],
+ license : 'LGPL 2.1+')
# TODO: Extract this from project.version.
# Ideally the version at Documentation/conf.py should be
@@ -16,7 +16,7 @@ api_version = '0.1'
cc = meson.get_compiler('c')
config_h = configuration_data()
-if cc.has_header_symbol('stdlib.h', 'secure_getenv', prefix: '#define _GNU_SOURCE')
+if cc.has_header_symbol('stdlib.h', 'secure_getenv', prefix : '#define _GNU_SOURCE')
config_h.set('HAVE_SECURE_GETENV', 1)
endif
@@ -28,8 +28,8 @@ common_arguments = [
c_arguments = common_arguments
cpp_arguments = common_arguments
-add_project_arguments(c_arguments, language: 'c')
-add_project_arguments(cpp_arguments, language: 'cpp')
+add_project_arguments(c_arguments, language : 'c')
+add_project_arguments(cpp_arguments, language : 'cpp')
libcamera_includes = include_directories('include')
@@ -41,14 +41,14 @@ subdir('utils')
# through configuration values. They are enabled by default.
if get_option('documentation')
- subdir('Documentation')
+ subdir('Documentation')
endif
if get_option('tests')
- subdir('test')
+ subdir('test')
endif
-configure_file(output: 'config.h', configuration: config_h)
+configure_file(output : 'config.h', configuration : config_h)
pkg_mod = import('pkgconfig')
pkg_mod.generate(libraries : libcamera,