summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2018-12-12 14:27:20 +0100
committerJacopo Mondi <jacopo@jmondi.org>2018-12-13 08:51:05 +0100
commit3b56ddaa96fbccf4eada05d378ddaa1cb6209b57 (patch)
treeb9e738613b909ec434dc8c3cdaa3a2cac26b99d1 /meson.build
parent6ab3ff4501fcfa24db40fcccbce35bdded7cd4bc (diff)
build: Add 'std=c++11' cpp compiler flag
Building the current master branch with g++ 5.4.0-6 fails with: ./src/libcamera/include/log.h:25:34: error: defaulted and deleted functions only available with -std=c++11 \ or -std=gnu++11 [-Werror] LogMessage(const LogMessage&) = delete; Fix this by adding the 'std=c++11' compiler argument for to the list of cpp build flags. Signed-off-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2fdb166c..7b6e2fec 100644
--- a/meson.build
+++ b/meson.build
@@ -17,6 +17,7 @@ common_arguments = [
c_arguments = common_arguments
cpp_arguments = common_arguments
+cpp_arguments += '-std=c++11'
add_project_arguments(c_arguments, language: 'c')
add_project_arguments(cpp_arguments, language: 'cpp')