summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristian Rauch <Rauch.Christian@gmx.de>2021-12-16 23:53:31 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2022-01-03 23:33:40 +0000
commit1db1e31e664c1f613dc964d8519fe75d67b154b6 (patch)
tree273a5c2696f4c738c3621b2e604a8879bc237867 /meson.build
parent152adad97a95c15ae9ac2e1889f94a3dc6412165 (diff)
meson: reduce required version to 0.53
Building the libcamera Android layer currently makes use of features from meson 0.55. The core libcamera framework in the default configuration without android enabled uses the 'summary' feature available in 0.53, and is the lowest supportable meson version if the Android HAL is excluded. Ubuntu 20.04 LTS currently provides meson 0.53 and represents an acceptable minimum version to support. Platforms utilising the Android component will have full control over their build environment and can ensure that they provide a more recent version of meson. Reduce the supported meson version for the project to 0.53 to facilitate building on more distributions without having to manually update the meson package. Meson will output a warning that features not available in 0.53 are used if the Android HAL is enabled. This is considered as an acceptable middleground to improve the experience on the latest Ubuntu LTS, until 22.04 LTS is released and provides a newer meson version. Signed-off-by: Christian Rauch <Rauch.Christian@gmx.de> [Kieran: Add comment about the android meson requirements] Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a20cc29e..9684d562 100644
--- a/meson.build
+++ b/meson.build
@@ -1,7 +1,11 @@
# SPDX-License-Identifier: CC0-1.0
project('libcamera', 'c', 'cpp',
- meson_version : '>= 0.55',
+ # Use of the Android component requires meson 0.55, but Ubuntu 20.04 LTS
+ # ships meson 0.53. Improve the Ubuntu experience at the expense of
+ # Android as the former is a much more common use case than the latter at
+ # this point. This should be fixed after Ubuntu releases 22.04 LTS.
+ meson_version : '>= 0.53',
version : '0.0.0',
default_options : [
'werror=true',