summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJean-Michel Hautbois <jeanmichel.hautbois@ideasonboard.com>2021-08-19 14:51:56 +0200
committerJean-Michel Hautbois <jeanmichel.hautbois@ideasonboard.com>2021-08-20 12:11:29 +0200
commit16266def40cda947aaa1a50009e89f639c26e7cf (patch)
tree519479c7ed2aa31388a4f11ed302171ff6ba20a5 /meson.build
parent4eb4073ec708ba1e4b4ef0375496dedc1308b3dc (diff)
ipa: ipu3: convert AGC to the new algorithm interface
In preparation for using the AGC through the new algorithm interfaces, convert the existing code to use the new function types. Now that the process call is rewritten, re-enable the compiler flag to warn when a function declaration hides virtual functions from a base class (-Woverloaded-virtual). We never use converged_ so remove its declaration. The controls may not need to be updated at each call, but it should be decided on the context side and not by a specific call by using a lock status in the Agc structure for instance. As the params_ local variable is not useful anymore, remove it here too. Signed-off-by: Jean-Michel Hautbois <jeanmichel.hautbois@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 0 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 4a10e2b6..a49c484f 100644
--- a/meson.build
+++ b/meson.build
@@ -108,10 +108,6 @@ if cc.has_argument('-Wno-c99-designator')
]
endif
-# Do not warn when a function declaration hides virtual functions from
-# a base class
-cpp_arguments += '-Wno-overloaded-virtual'
-
c_arguments += common_arguments
cpp_arguments += common_arguments