summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2019-07-10 20:29:44 +0900
committerPaul Elder <paul.elder@ideasonboard.com>2019-07-11 12:22:40 +0900
commit10ec09025d6f52f2c1d0ba6b7e6943a603a386d9 (patch)
tree88155bb4924380641b1212219f5b697b121177ca /meson.build
parent6a27bd33879970e182949ad2010687886d2dc671 (diff)
libcamera: skip auto version generation when building for Chromium OS
Commit b817bcec6b53 ("libcamera: Auto generate version information") causes the build to fail in the Chromium OS build environment, because git update-index tries to take a lock (ie. write) in the git repo that is outside of the build directory. The solution is to simply skip git update-index if we are building in the Chromium OS build environment, and this decision is made if the build directory is not a subdirectory of the source directory. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 8f3d0ce9..13d0605f 100644
--- a/meson.build
+++ b/meson.build
@@ -15,7 +15,7 @@ project('libcamera', 'c', 'cpp',
# git version tag, the build metadata (e.g. +211-c94a24f4) is omitted from
# libcamera_git_version.
libcamera_git_version = run_command('utils/gen-version.sh',
- meson.source_root()).stdout().strip()
+ meson.build_root()).stdout().strip()
if libcamera_git_version == ''
libcamera_git_version = meson.project_version()
endif