summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2020-09-01 14:59:49 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2020-09-07 17:06:19 +0100
commit094b3001fd7dc755f3a2804f7de73c09ea27dc8b (patch)
treec3cbbd7be3236ccf92e34b49b3b78b04f1e5e3af /meson.build
parent8117ab0a320029f97540aed2a9eebf3c759b8879 (diff)
meson: Provide build configuration summary
Report the enabled pipelines when configuring the meson build hierarchy. This helps clarify what pipelines are used when building, and is useful when looking back through build-traces to see what was actually configured. This can be expanded upon to report other options, and ideally will be replaced by mesons summary() functionality when it is available. Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b6c99ba8..1ea35e92 100644
--- a/meson.build
+++ b/meson.build
@@ -141,3 +141,6 @@ pkg_mod.generate(libraries : libcamera,
filebase : 'camera',
description : 'Complex Camera Support Library',
subdirs : 'libcamera')
+
+## Summarise Configurations
+message('Enabled pipelines: ' + ', '.join(get_option('pipelines')))