summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2021-01-27 01:23:51 +0100
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2021-04-12 10:48:56 +0200
commit02bc1108578e8b8eb68fa7d9ae3eeea558723931 (patch)
tree42e99d5d3cfa45b25651e0175b44400823efdfe2 /meson.build
parent43ab65df8dd2fd6ef3336fdb1f56909661de2475 (diff)
lc-compliance: Add a libcamera compliance tool
Add a compliance tool to ease testing of cameras. In contrast to the unit-tests under test/ that aims to test the internal components of libcamera the compliance tool aims to test application use-cases and to some extent the public API. This change adds the boilerplate code of a simple framework for the creation of tests. The tests aim both to demonstrate the tool and to catch real problems. The tests added are: - Test that if one queues exactly N requests to a camera exactly N requests are eventually completed. - Test that a configured camera can be started and stopped multiple times in an attempt to exercise cleanup code paths otherwise not often tested with 'cam' for example. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Acked-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Tested-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Tested-by: Jean-Michel Hautbois <jeanmichel.hautbois@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3a615ae3..13d88301 100644
--- a/meson.build
+++ b/meson.build
@@ -173,5 +173,6 @@ summary({
'V4L2 emulation support': v4l2_enabled,
'cam application': cam_enabled,
'qcam application': qcam_enabled,
+ 'lc-compliance application': lc_compliance_enabled,
'Unit tests': test_enabled,
}, section : 'Configuration')