summaryrefslogtreecommitdiff
path: root/include/libcamera/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2019-06-27 17:49:57 +0100
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-07-01 02:26:55 +0300
commitdba2de3a0feddddf2774b75c1bcc8ed0c6bd54c5 (patch)
tree3a12cf6c6f96bde7f4ae5221055722e8b67d7885 /include/libcamera/meson.build
parent6f0c4d07420a94863a986123dffc61cf4c8235ba (diff)
libcamera: Use 'files()' function to specify gen-header.sh
The files() function generates a variable with the location of the referenced files. This is shorter than joining the current_source_dir() of which use is somewhat frowned upon. Fixes: 90de3690c456 ("libcamera: Auto-generate libcamera.h") Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'include/libcamera/meson.build')
-rw-r--r--include/libcamera/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/libcamera/meson.build b/include/libcamera/meson.build
index 1b86fdc7..15484724 100644
--- a/include/libcamera/meson.build
+++ b/include/libcamera/meson.build
@@ -14,7 +14,7 @@ libcamera_api = files([
'timer.h',
])
-gen_header = join_paths(meson.current_source_dir(), 'gen-header.sh')
+gen_header = files('gen-header.sh')
libcamera_h = custom_target('gen-header',
input : 'meson.build',