summaryrefslogtreecommitdiff
path: root/include/libcamera/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-09-21 03:08:26 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-11-08 00:11:12 +0200
commit79c34d58c7bb005efabbb960f66b9dfd11cb36ec (patch)
treec5af239ece87514568ae29f56701b99ca40f2c1c /include/libcamera/meson.build
parent6cd1baa28d8ab0babb766de7a59d10f38fbd786d (diff)
libcamera: Add a base class to implement the d-pointer design pattern
The d-pointer design patterns helps creating public classes that can be extended without breaking their ABI. To facilitate usage of the pattern in libcamera, create a base Extensible class with associated macros. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'include/libcamera/meson.build')
-rw-r--r--include/libcamera/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/libcamera/meson.build b/include/libcamera/meson.build
index 3d5fc701..0b891a8f 100644
--- a/include/libcamera/meson.build
+++ b/include/libcamera/meson.build
@@ -8,6 +8,7 @@ libcamera_public_headers = files([
'controls.h',
'event_dispatcher.h',
'event_notifier.h',
+ 'extensible.h',
'file_descriptor.h',
'framebuffer_allocator.h',
'geometry.h',