summaryrefslogtreecommitdiff
path: root/include/libcamera/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2020-03-06 17:20:30 +0000
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-03-08 19:34:01 +0200
commit4ed68766435703f41a11caf7066d0396bd92aa1e (patch)
tree24276c767270af4452d8ad45d2f11889eaf3fdf9 /include/libcamera/meson.build
parent00804512c6c091b3062beced6085b1b65badb8b8 (diff)
include: libcamera: meson: Add control headers to the libcamera_api array
The libcamera_api array is meant to contain all the headers from the libcamera public API, for the purpose of generating documentation and creating the libcamera_dep dependency. The generated control headers are part of the libcamera public API, and used to be included in the libcamera_api array until commit f870591a9bf5 ("libcamera: properties: Add location property") inadvertently removed them. Add them back. Fixes: f870591a9bf5 ("libcamera: properties: Add location property") Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> [Split the change out and reworded the commit message] Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'include/libcamera/meson.build')
-rw-r--r--include/libcamera/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/libcamera/meson.build b/include/libcamera/meson.build
index f47c583c..88edf620 100644
--- a/include/libcamera/meson.build
+++ b/include/libcamera/meson.build
@@ -44,6 +44,8 @@ foreach header : control_source_files
install_dir : join_paths('include', include_dir))
endforeach
+libcamera_api += control_headers
+
gen_header = files('gen-header.sh')
libcamera_h = custom_target('gen-header',