summaryrefslogtreecommitdiff
path: root/include/libcamera/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2019-06-19 16:56:40 +0100
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-07-02 16:59:20 +0300
commit20d5640ca49c76c89be5bebcc00981942c7a9c19 (patch)
tree2df084fecebca0484467093def94e443d1d6459b /include/libcamera/meson.build
parenta110cc94ab5dfb26bf6a5eae61ea5ba2deb6d3f3 (diff)
libcamera: controls: Introduce control-related data types
Add a set of data types to support controls: - ControlValue stores a control type and value in a generic way - ControlId enumerates all the control identifiers - ControlIdentifier declares the types of a control and map their names - ControlInfo stores runtime information for controls - ControlList contains a set of control info and value pairs The control definitions map is generated from the controls documentation to ensure that the two will always be synchronised. Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'include/libcamera/meson.build')
-rw-r--r--include/libcamera/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/libcamera/meson.build b/include/libcamera/meson.build
index 15484724..3067120a 100644
--- a/include/libcamera/meson.build
+++ b/include/libcamera/meson.build
@@ -2,6 +2,8 @@ libcamera_api = files([
'buffer.h',
'camera.h',
'camera_manager.h',
+ 'control_ids.h',
+ 'controls.h',
'event_dispatcher.h',
'event_notifier.h',
'geometry.h',